SVERWEIS() und WVERWEIS() „für Dummies“ – einfach erklärt

Wer als Excel-Anwen­der die ers­te Bekannt­schaft mit dem SVERWEIS() oder WVERWEIS() macht, mag es nicht glau­ben: aber wenn man die­se Funk­tio­nen erst ein­mal gemeis­tert hat, kommt man nur schwer wie­der davon los! Sie sind hilf­reich, spa­ren Tipp­ar­beit und sind eigent­lich unver­zicht­bar, wenn man effi­zi­ent mit Excel arbei­ten möch­te. Die Anwen­dung der For­meln ist nicht schwie­rig. Wet­ten, Sie ken­nen die For­meln nicht nur aus Excel? Ich behaup­te: wenn Sie beim Ita­lie­ner eine Piz­za bestel­len kön­nen, dann kön­nen Sie auch den SVERWEIS()! 

SVERWEIS() und WVERWEIS() im Alltag

Zu den For­meln SVERWEIS() und WVERWEIS() gibt es vie­le Anlei­tun­gen. Man­che sind aber so kom­pli­ziert und abs­trakt, dass sie für die Excel-Anwen­der oft eher abschre­ckend wir­ken. Das ist scha­de. Denn im Grun­de sind bei­de For­meln sim­pel und Sie brau­chen kei­ne Angst vor ihnen zu haben!

Star­ten wir mit zwei Bei­spie­len aus dem Alltag!

SVERWEIS am Beispiel einer Pizzakarte
SVERWEIS() beim Italiener

SVERWEIS()

Was kos­tet die Piz­za “Sala­mi” in der Vari­an­te “groß”?

Wenn Sie 7,50 € her­aus­ge­fun­den haben, dann haben Sie den SVERWEIS() rich­tig ange­wen­det.
Ein­fach, oder?

Sie haben in der ers­ten Spal­te nach „Sala­mi“ gesucht und dann in der Spal­te 3 geschaut, was die Piz­za Sala­mi in der Vari­an­te „groß “ kos­tet.

Das S in SVERWEIS() steht für die senk­rech­te Suche des Such­be­griffs von oben nach unten in der ers­ten Spalte.

WVERWEIS()

Beim WVERWEIS() funk­tio­niert die Suche genau anders­her­um. Man durch­sucht die Spal­ten­köp­fe einer Tabel­le nach einem Begriff und liest dann in der rich­ti­gen Zei­le den gesuch­ten Wert ab.

Klingt kom­pli­ziert? – Wel­ches Des­sert gab es denn am Mittwoch?

WVERWEIS am Beispiel einer Menükarte

Sie suchen in der ers­ten Zei­le die Spal­te „Mitt­woch“ und schau­en dann in der Zei­le 5 der Tabelle.

So ein­fach ist der WVERWEIS() !

Das „W“ in WVERWEIS() steht für die waage­rech­te Suche des Such­be­griffs in der ers­ten Zei­le von links nach rechts.

Die Formeln des SVERWEIS() und WVERWEIS() in Excel

Las­sen Sie sich von den For­meln in Excel bit­te nicht erschre­cken! Sie wer­den das Mus­ter bald ver­in­ner­li­chen. Sie brau­chen es auch „nur“ ver­ste­hen, aber nicht aus­wen­dig können. 

Excel hilft Ihnen! Wenn Sie die For­mel ein­tip­pen, zeigt Ihnen Excel die benö­tig­ten Anga­ben der For­mel an, sobald Sie ( gedrückt haben. (Das gilt übri­gens grund­sätz­lich in Excel.)

SVERWEIS() mit den benötigten Angaben in der Formel

=SVERWEIS(Suchkriterium; Matrix; Spal­ten­in­dex; [Bereich_Verweis])

Such­kri­te­ri­um:      “Was?” – Gemeint ist der Begriff, nach dem Sie suchen.

Matrix:                 “Wo?” Such­be­reich Ihrer Tabel­le, in dem Sie Infor­ma­tio­nen suchen

Spal­ten­in­dex:        “In wel­cher Spal­te?” befin­det sich die gesuch­te Infor­ma­ti­on
(Ach­tung: die Spal­te mit den Such­be­grif­fen zählt mit!)

[Bereich_Verweis]: “unschar­fe Suche?” – Die­se Ein­ga­be ist eigent­lich optio­nal, in 99,9 % der Fäl­le ist aber die Ein­ga­be „FALSCH“ oder „0“ nötig, damit Sie die genaue Suche ein­schal­ten und kei­ne fal­schen Ergeb­nis­se erhal­ten. Sie soll­ten sich ange­wöh­nen, die­se Ein­ga­be immer zu machen. „FALSCH“, damit es rich­tig wird! 

Im nor­ma­len Sprach­ge­brauch wür­de man den SVERWEIS viel­leicht for­mu­lie­ren:
=SVERWEIS(Was?; Wo?; in wel­cher Spal­te?; [unschar­fe Suche?])

Die For­mel des WVERWEIS ist ana­log auf­ge­baut, aber mit dem „Zei­len­in­dex“, statt des Spaltenindex.

=WVERWEIS(Suchkriterium; Matrix; Zei­len­in­dex; [Bereich_Verweis])

Beispiele für die Verwendung von SVERWEIS und WVERWEIS

Am Bei­spiel einer Umsatz­ta­bel­le sehen Sie die unter­schied­li­che Her­an­ge­hens­wei­se bei der Anwen­dung der bei­den Funk­tio­nen. Die Ergeb­nis­se bei­der For­meln sind in die­sem Bei­spiel gleich. Nur ein­mal sucht man von links nach rechts und ein­mal von oben nach unten.

SVERWEIS und WVERWEIS im Vergleich
"Verkäufe der Röcke im Mai" oder
"im Mai verkaufte Röcke".
SVERWEIS und WVERWEIS im Vergleich

Beim SVERWEIS() suchen Sie in der 1. Spal­te die „Röcke“ (Tref­fer in Zei­le 4 der Matrix) und fin­den dann in der 6. Spal­te den zuge­hö­ri­gen Wert für „Mai“.

Beim WVERWEIS() suchen Sie in der 1. Zei­le den Monat „Mai“ (Tref­fer in Spal­te 6 der Matrix) und fin­den dann in der 4. Zei­le den Wert für „Röcke“.

Sie haben die Mög­lich­keit, den Such­be­griff direkt in die For­mel zu schrei­ben („Röcke“, „Mai“) oder bes­ser, mit einer Zel­le zu verknüpfen.

Excel-Formel mit Bezug zu Zelle mit Suchbegriff

Wenn Sie jetzt in der ver­knüpf­ten Zel­le (C16) den Such­be­griff von “Röcke” auf “Blazer“ändern, erhal­ten Sie das rich­ti­ge Ergeb­nis. Die For­mel des SVERWEIS() müs­sen Sie dazu nicht mehr ändern

Erweitern einer Tabelle

Eine häu­fi­ge Ver­wen­dung von SVERWEIS() ist das Erwei­tern einer bestehen­den Tabel­le um eine Spal­te mit Wer­ten, die aus einer ande­ren Tabel­le „gezo­gen“ wer­den. So ver­mei­den Sie dop­pel­te Daten­ein­ga­ben und mög­li­che Tippfehler.

SVERWEIS zum Erweitern einer Tabelle

Tipp: wenn Sie die Zel­len der Matrix “abso­lut” ange­ben, wird die For­mel beim Kopie­ren nach unten nicht ver­än­dert. Schrei­ben Sie also statt z.B. C2:H6 dann $C$2:$H$6. Alter­na­tiv kön­nen Sie die­sen Teil der For­mel auch mar­kie­ren und dann mit der Tas­te F4 die Dol­lar­zei­chen einfügen.

Häufige Fehlermeldungen

#NV!
Die­se Feh­ler­mel­dung erscheint, wenn der Such­be­griff nicht gefun­den wer­den konn­te. Ent­we­der kommt der Such­be­griff tat­säch­lich nicht vor oder – meis­tens – Sie haben sich verschrieben.

#BEZUG!
​Die­se Feh­ler­mel­dung tritt auf, wenn man beim Spal­ten­in­dex eine Spal­te ange­ge­ben hat, die sich außer­halb des Such­be­reichs befin­det. Bei­spiel: Bei einem Such­be­reich mit nur zwei Spal­ten gibt man, die Zahl 3 als Spal­ten­in­dex an. Oder beim Kopie­ren der For­mel hat sich in der For­mel die Matrix verändert.

#WERT!
Die­se Feh­ler­mel­dung tritt auf, wenn man beim Spal­ten­in­dex 0 oder eine nega­ti­ve Zahl ein­trägt. Der SVERWEIS schaut immer nur nach rechts, es ist also nicht mög­lich, links von der ers­ten Spal­te zu suchen.

#NAME?
Die­se Feh­ler­mel­dung tritt auf, wenn man sich bei der Funk­ti­on ver­schrie­ben hat und anstatt SVERWEIS z.B. “=ser­weis” ein­ge­ge­ben hat.

Fazit

Jetzt haben Sie alles Wich­ti­ge zum Excel SVERWEIS() und WVERWEIS() kennengelernt.

Am bes­ten ver­su­chen Sie jetzt gleich ein­mal selbst, die For­meln anzu­wen­den. So lan­ge, bis es bei Ihnen „Klick“ gemacht hat. Übung macht den Meister!

Eins ist gewiss:
Sie wer­den die­se For­meln lie­ben und nicht mehr mis­sen wollen! ?

Excel-Tipps (nicht nur) für Controller

Excel-Tipps (nicht nur) für Controller.
eBook als PDF
kos­ten­frei­es eBook mit Tipps zu For­ma­tie­run­gen und For­meln – hier im Blog

Ein Kommentar

Kommentar verfassen